output style numbering

I’m having problems getting Endnote X4 to number the citations the way I want in my paper.  This is what I want -

All these references talk about the same thing (superscript) 1-4

This is what I have now - 

All these references talk about the same thing [1,2,3,4]

I understand how to get superscript references, but I don’t know how to get 1-4 instead on 1,2,3,4.


The setting is a tick box in the output style, citation, numbered setting (the first one which is ticked in this example and should produced the [1-4] I think you want).  However there are some “output styles” out there from an earlier version of endnote that changes in the numbering aren’t applied as expected.  The safest thing to do in that case is to jetison the version of the style you are using and download a fresh one from the Help, Web styles finder and try adjusting that to your requirements. 

Ah!  Thanks for the attached GIF, I still had the grouped references box checked.