problem putting author name in square brackets in bibliography

In cases where the author’s name is known but attributed post hoc it is common to put the name in brackets thus:

[Rohde, E.] (1872) TITLE

At the moment, my style sheet looks like this:

Author (Year) Title|

but when I enter the author’s name into the endnote db with [NAME] the output looks like this:

[Rohde, E. (1872) TITLE

I don’t want to create a new style for these rare cases if I can avoid it, e.g.

 [Author] |(Year)| Title|

I’d like to figure out what is causing the problem. Fiddling around with horizontal bars makes no difference, so I assume the brackets are sending a signal to EndNote, but what kind?

Many thanks


Message Edited by jiporter on 12-20-2009 04:02 PM

The EndNote styles have a “clean up” function.

As the manual explains, “Normally, field text is entered into EndNote without ending punctuation, so that the selected output style can supply punctuation as required by that particular style … EndNote must determine what to do with any punctuation that already exists at the end of the field in the reference.”

So I think it is “cleaning up” the square bracket at the end of the Author field.

I don’t know of any workaround. As you say, you could set up a custom reference type for such references. It’s another one of the many problems that researchers in the humanities have to deal with when using EndNote.


Thanks, yes that is what I ended up doing, as nothing else worked. What it involved, though, was copying, manually, my reference type settings in the preferences from one style to the new style which I named “[Author]”. That was a bit of a drag, as I had to compare by going back and forth repeatedly till I was satisfied I had them down exactly the same, since they had to be exact duplicates.

So, next related question: is there a way (for future reference) to duplicate reference types in the preferences in a simpler fashion? I don’t see any in the manual (X3). But I could easily have missed it. 

When you are in the Reference Type preferences in EndNote, you will see an option to export the Reference Type Table.

Do this. Save it as an XML file. Make a copy, and work with the copy, so that you can always go back and reimport the original, if things go wrong.

I’ve no experience with editing XML files, but I just opened it in a plain text editor (Notetab), and did a search for “Unused”. When I found the Unused ! reference type, I changed the name to [Author].

Then I did another search for “Book” to find the Book reference type. I carefully copied all the data between the <Fields> tag and the </Fields> tag, and then pasted this into the [Author] section.

I saved the amended file and went back to the EndNote Preferences and imported it. It seemed to work correctly and set up the new [Author] reference type, with all the fields from the Book reference type. 

1 Like