Problem with diacritics in WorldCat


I’m exporting records from my library’s version of WorldCat Local (i.e., Diacritics are preserved when I export records individually, but if I export a set of records from a saved list, the diacritics do not display properly.

See attached examples of the same item exported individually (“right”) and as part of a list (“wrong”).

Has anyone else noticed this? Is there anything to do about it? 



I don’t know if this is the problem, but when you import the file, have you selected the translation to use Unicode-UTF-8?  

Sorry, I should have specified that I was doing a direct export from the web browser.

However, I just tried downloading the records as an RIS file and importing it with the UTF-8 option for text translation. Alas, the diacritics are still not displaying properly. 

Does WorldCat produce a RIS file with the diacriticals?  I know that a database I used did not.  

The diacritics are preserved in the RIS file when I export a single item directly from the record in the database. For example, see, exported using the “Cite/Export” button. 

The diacritics do NOT appear in the RIS when I export a list of records. For example, see to the “citations view” to export.

I’ve attached the respective RIS files as .txt files (we can’t attach .ris in this forum).

I’ve written to WorldCat to see if they could explain whether the lists vs. individual records have a different structure in some way, but I haven’t heard anything back. 

Again, the diacritics don’t display properly even if I save the RIS file for the multiple records and import with UT-8 encoding.

worldcat_list_ris.txt (2.33 KB)
single_record_ris.txt (288 Bytes)