Problem with EndNote XI and CWYW


I work for an English University and am having some problems getting the Cite While You Write feature to work properly. Our PCs are running Windows XP Pro, EndNote XI and Office 2007 incidentally.

The problem is getting the EndNote toolbar to appear in Word for each student that logs onto one of our PCs. Obviously the students do not have Administrator access on the PCs and having to run the “Configure EndNote” tool each and every time they log on is hardly an ideal solution. 

I’ve tried creating a login script which runs the “regsvr32 “EndNote CWYW.dll”” command, however this doesn’t seem to like being run without administrator rights.

So! Is there any solution that will allow a restricted user to log onto a PC, launch Word and have the EndNote toolbar appear without any additional hassle?

Thanks in advance!


There’s an FAQ with assorted fixes from the EndNote support site concerning the toolbar appearing in Word and CWYW:

I have already read that page and it’s of little use. The 2 solutions they list are:

The simplest way to get the tools to appear in Word 2007 is to run the Configure EndNote Utility from the EndNote Start Menu or the EndNote X1 Program Files folder. Once you run the utility, make sure “Configure EndNote components for me” is selected and click Next. Select the “Unified Cite While you Write for the Microsoft Word” and the “Set EndNote as default reference manager for Word 2007” options and click Next. Click Finish when you are done.

Unfortunately, this would have to be done for each user, each time they log onto a PC. As you can understand, having to get each student to manually run a configuration program each time they log on is hardly an ideal solution. If and when we upgrade to X2 or X3, the problem gets worse as the solution for those EndNote versions is to go into Control Panel, Add & Remove Programs and run a repair of the installation - something our students do not have sufficient privileges to do

The second solution listed is to fire up a command promt and run:

regsvr32.dll “EndNote cwyw.dll”

Unfortunately as I mentioned above, this command requires administrator rights and therefore will not work under our student accounts - which is a pity as it’d otherwise work fine in a login script. Don’t suppose there’s any other ways of getting it working?

(Sorry for posting this over 2 messages, the board kept complaining that it was over 20,000 characters when I tried to post it as one message - even though it isn’t).

Message Edited by Trippynet on 11-02-2009 08:42 AM

I don’t think this issue is addressed by single-license based users at the forum. There are little attendance of IT/networking professionals here. How about calling Thomson Reuters directly?

See these support pagesand the associated FAQs.

However, it looks to me  like what you are looking for, was implemented in X2.

Message Edited by Leanne on 11-02-2009 12:03 PM