record numbering, library problem - EndNote X7.1

I couldn’t find a topic addressing this so I am sstarting a new one.  The problem I have was caused by TR’s endnote online sync and my own belief that this type of product would work correctly and provide sufficient warnings.

I had a lot of problems with the original X7 sync and so stayed away from it for a while.  they said the fixed it in X7.01.  Now I am using X7.1 and I decided to go ahead and try it again.  I made the mistake of completely deleting all references in  my endnote online account, then trying to sync without first resetting the local sync preferences (I have suggested that this should be a button in the GUI, instead of a word document they send out to those who ask).  When I started to sync it was already late in the day so I left it syncing and went home.  The next morning I came in and there were 700 less citations in my library and the number was going down.  I stopped the sync and contacted the TR support group.  Resetting the local sync preferences fixed the initial problem, but now I had to find out what had been deleted.  I spoke to a technical rep and he said to send him the backup compressed file I had along with the new one and he would fix it.  I asked explicitly that the references be put back with the same numbers they had before and that I knoew this was not ordinarily possible, but could it be done with and RIS export and reimport?  He assured me it could.

At the end of the day, I received the file back, but it had too many references in it.  I checked it out and found that at least some were duplicates.  The references that were put back had some information missing and the records had just been added onto the end (new record numbers).

Does anybody know of a way to fix this?

First make copies of both libraries (so you can go back if necessary).

I have been told that synched llibraries do not necessarily retain the same record numbers.  I would go back to tech support on this, as I doubt any of us will be able to resolve the issue.  If you have the compressed library, I would fix it my self.  I would first turn off any synching.  

What I have done, is to copy the Record number into an unused field for future reference (in both libraries).  I precede it with a unique three letter code and follow it with a unique keyboard character, as the field is a text field and the number can’t be uniquely found by searching for it (so otherwise a search for 14 would return 14, 140, 141 214, etc).  Then I would import the one into the other - importing with discard duplicates.  Which is the recipient and which is the importee, depends on the libraries and which is going to give you back the bulk of your records with the right record number.  

Then, before resynching I would get the instructions to start with a new online sync library.  – Yes it will take forever again, but this is the only way I have found to keep the numbers.  To do this, you need to reset something with your email address/login and then again. Tech support should be able to give you the instructions.  

Yes they sent instructions on how to reset the local library sync status (attached).  Although this does not  solve my problem.  They have bumped the problem up to the next support level, but I am not hopeful that this can be solved to my satisfaction.  For a large company, TR is not doing a very good job of PR since the release of X7 and the sync problem.

Reset Sync (12.3 KB)

This is totally unacceptable; they advertise that this product syncs libraries but then completely fails to sync record numbers. This causes major issues when working from 1 database to another in a team environment with references being inconsistently numbered. This needs to be fixed ASAP; I am very frustrated with Endnote right now.

I’m trying to find a decent workaround and this is not even working for me. BTW I have updated to the latest version of Endnote (X7.2.1). I feel like the people who designed this software never actually worked with it -.-

I have a macro that copies record numbers to the call number field of that helps.

unfortunately it doesn’t help much for the purposes of Endnote knowing what is what, as the number isn’t a “unique” matching process with other fields.  100 brings up 10100, 1001, 1002 and other variants with paritial matches.  

What exactly are you trying to do?

I’m having the same problem. I’m sharing a library with a co-writer. We have been using Scrivener and Word 2016 (where the multiple author is a complete hack btw), so all references has been entered as temporary citations. We’re now in the final phase of our paper, and just discovered that our libraries – that have been synced with Endnotes built in sync from day 1 – are a complete hash of different record numbers. Sometimes it’s an increment of 1, other times the difference is in the 100s. Or 132s or 34s or 195s. There is no system.

The reason we used a reference manager and continously syncing it online is not to have to be afraid of getting citations mixed up. Now not only do we need to go through all of our document, replacing all the wrong record numbers manually, but we also have a series of authors that have written multiple articles the same year, so these instances has to be read through and actually researched. Luckily we often attach page numbers, but still.

_How is this even possible. _You would think that if it is ONE thing the sync should pay attention to is matching record numbers, as everything relies on it. I tried updating the fields to citations, and used almost quarter of an hour just blindly hitting OK to “resolve” all the erroneous citations.

BTW: We have been using Endnote 7 through the whole process, steadily upgrading as updates came along.


That sounds awful!  There is a definite problem with sharing libraries for this very reason and I have suggested many times that TR fix this in endnote, but apparently it is not an easy fix (since it hassn’t been done yet).  I’m told that the developers are working on something that would fix this.  In the meantime I use an Autohotkey (ahk) script to do several things on all new publications/citations in my library.  I have one script that just autoumatically says yes to any questions that pop up when you select a slew of publications and then select “Find Reference updates.”  This script should only be used after you have backed up your library (I have a script for that as well, but the built in works fine).  Then I have an update script that checks each citation and replaces information, interactively, in the custom 8 field (I use that for excludes in searches), and the reviewed item field.  It then puts the record number in the call number field, the pmid in the label field, changes the access dat to the current day.

If you are interested in the script, let me know (  Just remember that the update script updates all fields.  My library is verycustomized and I have yet to have a problem with this, but if you chang things like the title or alter the authors, this could be a problem.

I’m running Endnote X7.5, and this still hasn’t been fixed?  I’m of the “how is this even possible” opinion–for the very same reason bonka describes: I’ve got a document that includes multiple instances of an author with two publication in the same year–and no way to sort them out except to go back and find copies of all the articles.  This is nuts!! 

Is there some hint for figuring out the system?  The numbers seem to be off by hundreds or thousands: #2745 might now be #3452…a seemingly random change. Probably more important, how do I know when/what will change in the future? Is there any sort of pattern to what the sync process is doing? 

The various workarounds offered seem to suggest creating a unique label of our own (which makes me wonder why Endnotes still has a record number at all, if it’s no longer really a record number.)  But, if I add a citation, which is always with curly brackets, do I then need to include that identifyer?  Won’t that then show up in the citation when I format the bibliography?

PS: Hi Leanne! Nice to know you’re still out here.

Hi!  Still not of retirement age!  

Use the pages field instead of the record number?  

That’s a field that’s already in use, however. I’m not sure how those who recommed that get around the screwing up bibliography.  

The only field that seems safe would be Label, but I’ve used that to indicate where the source is physically located.  (Thank goodness I have that when I have to go find all these sources again!!  I guessed as best I could for the submission that was due immediately, but I’m going to have to get these sorted out before the final version.)

The only colleague who actually used the online Endnotes has now retired, so I could just unsync myself, right?  However, I was starting to run into problems with keeping my library in Dropbox, which allowed me to use the same library from both work and home. If that problem has been solved, abandoning the online version would seem to be Plan A?


no – it uses the page numbers to match rather than the record number – you make the change in preferences, and it uses that from then on in all the documents – updating it once with the original sorts it out for ever.  

And no-- still can’t use dropbox. – – unless you are extreeeeeemly careful that it is full closed (I would log out) in each location so it isn’t ever open in two places. – that is what corrupts it.  

Or you copy the whole library (.enl file and the .DATA folder) from work to dropbox and then copy them  to the home machine, (and then copy the whole thing back to dropbox if you added anything), etc.  –  so you don’t open it on dropbox directly.  

I do that on occassion and try very hard not to add any records to the library at home ever, so I don’t need to copy it back, but can use it as I write.  

That sounds very smart…but I don’t have an option for that in my Edit/Preferences/Sync. That just gives the path to my online library and password, but no options for anything.  

Hmm, just tried my idea, and it doesn’t seem to convert record numbers to pages, unless they are newly inserted.  It reads the old ones fine (but mine don’t have any disconnects) but it may only be a proactive way to avoid the problem, not a retrospective solution.  Sorry

You can’t sync a library on dropbox.  

It would have to be to desktop versions? Are you syncing now to a dropbox version? I really don’t understand what you are saying.  I don’t use sync at all.  I just move them back (and rarely forth).  

or  - are we back to using page numbers.  That I don’t know - -as I don’t sync.  

I have one library, but I work both at home and at campus, so I need to keep them “as one”.  Dropbox just made things freak out.  My other option was to move the file onto and off the desktop at each location.  That was pretty workable, but still took some steps.

A couple of years ago, I began working with a colleague with only an online account. He got me set up to use that so we could collaborate.  I very, very seldom use the online interface because it’s so awful to work with, but it did create nice way to keep the libraries synced without any effort at all.

I didn’t even realize until this week that the record numbers were scrambled.  I’d run into one now and then when running the bibliography but I just assumed I’d had a duplicate entry. I figured I’d inserted the record that I’d later deleted, and so I woulld have to reinsert with the remaining record.  No big deal, although it did seem like I had more duplicates than I realized.

This week, however, I was running the bib for a paper that’s been “working” for quite a while, and I had a massive number of record numbers that didn’t match the bib. In most cases, the match was easy, but for those where the author and year are the same, the record number is the only other data point in the citation to help me decide which it was…but no longer!!  Once in a while, the sense of the sentence helps out, but really, when an author has published two things in the same year on the same general topic, it’s not foolproof. If there were a direct quotation, the page number could help, but it’s not a consistently available tool.

I’m thinking now I’d better just abandon the online account and go back to manually moving my library file.