References with URL

I have included a master’s thesis in my references. I would like the URL for this work (http ;…) appear in the references. I want to configure my endnote references that only the thesis may have your url. Although I’ve put the address: http://…in the reference, it does not appear in the text when I include this reference. How do I fix this problem?

Thank you

You don’t mention the output style you’re using but it sounds like the Thesis template is missing the “URL” field.  You will need to manually modify the template.  An overview of the procedure using the “Access Field” outlines the procedure(see discussion: ) but basically you will need to do the following:


  1. Go to the EndNote toolbar, select EDIT, OUTPUT STYLES, “EDIT  [Name of Style]”.  This will cause the style window to appear on screen.

  2. In the left column, locate “Bibliography” then click to select TEMPLATES.  Locate the “Thesis” template  by clicking the pull-down menu next to REFERENCE TYPES pull-down menu.

  3. In the Thesis template, note that the field “URL” field is probably missing.

  4. To modify the template, use the “Insert Field” drop down menu to insert command symbols and the URL field.

  5. Close the style window.  You will be prompted to save the changes.  If you elect to save the changes under a different name, don’t forget to change your style setting in EndNote and your wordprocessor to match, otherwise the the template changes won’t be operational.

P.S. Just a suggestion  but posting questions to the appropriate sections of the forum (e.g., “How to”, “Styles, Filters, and Connections”, or “General” ) would benefit other users who may be experiencing similar problems or help in identifying a resolution.