Space inserted in in-text citation for "insert in bibliography only."

How do I avoid this additional space being inserted? (APA 6th)

Unclear what you mean. Could you provide a specific example?

Do you have smart paste setting on in Word?  Word may be inserting the space automatically.  

My version of APA(6th) doesn’t insert any space when I edit a citation to “show only in bibliography” (I am working with EndnoteX7.3.1, Word 2013)  when I go to endnote and select my citation from the library and click on the curved down button to insert the citation in the word document.   

But I do get a trailing space inserted which remains after hidding the citation, if I ctrl-C in the library and then return to the document and ctrl-v.  This is because of smart pasting settings I am sure.  I am surprised the other route doesn’t trigger it as well.