Tip: How to eliminate slow Word 2011 typing when using EndNote X5 (for Macs)

I think I’ve discovered a trick that may help with those of using using Word 2011 and are experiencing slow cursor movement and typing ever since installing EndNote X5.

The trick is turn OFF “View Markup”. Now, when I’m just typing away regularly, I don’t use track changes but the “View Markup”, by default, is turned on.

To turn this off, go to View > Markup, and make sure the item is unchecked.

This seems to have work wonders for me.

P.S. I get the feeling that EndNote X5 continues to harbour old, old code from eons back. It’s such a clunky piece of software, even in its n-th revision.