Unwanted Commas

I’m presently encountering a number of unwanted commas at the end of the references within the bibliography.

Here’s an example of the template (Book) I’m using within Endnote (the template is American Economic Review):

Author. Title. City: Publisher|, Year,| Pages.

So I can certainly see how the comma would appear after the year of publication within the actual bibliography, according to the template shown above. There is obviously a comma after the Year.

But if I’m not including anything with respect to Pages, how do I get the comma to NOT appear in the bibliography?

Thanks in advance!


Author. Title. City: Publisher|,*Year|,*Pages|. 


where the * is a “link-adjacent” (available from insert field drop-down). 


Hello Leanne,

Thanks very much for taking the time to respond.

Unfortunately, even though I have followed your instructions precisely, it doesn’t seem to be working. The results in the individual bibliographies are the same.

Might you have any other suggestions…?

Thanks again!

attach the style so we can look at it. 


(and you are sure you haven’t edited one style, but your document is using the unedited version.  Check the format bibliography style, and try to unformat/reformat to make sure it is using the new style). 

How do I export/copy the Style itself, as to exporting/copying the entire library file? Or are you looking for a copy of the entire library file?


The edited styles are saved to the folder on your computer, where your preferences “folders” (styles) point.  I would need to know which version of Endnote you are using to say where this is likely to be.  (X2 or previous versions?). 

Then you just attach the specific style.ens file that you have been modifying.  When you respond to an email you will see a blue “Add Attachments” URL below the POST /CANCEL set of buttons.  you will click Add Attachments and browse to the folder where your edited styles reside and then after it is in the window, click POST. 

Thanks for the instructions. I just didn’t know where exactly to find the specific style file on my hard drive. =)

It is attached now.

Thanks! Looking forward to hearing from you.

Amer Economic Review-Kevin.ens (11.6 KB)

In addition to the link-adjacent, you still have the conventional spaces.  The link adjacent IS a kind of space.  You need to remove the space (tiny dot) and leave the tiny “o” symbol.  – but why for a book section, wouldn’t you have pages? 

1 Like


your style still has a comma after Year before vertical bar (forced separation). this comma belong to the presence of Year field, and that’s why you still have the comma before period.


As Leanne suggests, place the comma after the vertical bar. Then, the comma will be dependent on the presence of Pages, and will disappear when you don’t have Pages.

Thanks again. The removal of the small space seemed to have done the trick.

Much appreciated!

@leanne wrote:

… but why for a book section, wouldn’t you have pages?

Forgot to comment on this. The reason that I do not include the pages within the bibliography is because my professor requires that the citation itself contain the page numbers.

Thanks again!

yes, but that is usually the specific page that relates to the topic, not the range of pages that delineates the whole chapter. 

You bring up a good point here.  Thanks very much for your help.