in print and redundant comma


In Bibliography templates

Journal Article

Author, “Title,” Journal, |Vol. Volume, |Date |Year, |p.^pp. Pages|(in Language)|.

Then in Word, it shows:

Li, X. X., “Title,” Journal of XXX, (in print).


                                                   This comma is redundant.

How to eliminate it?


You could modify the output style template to move commas and insert “link with adjacent text” commands (noted by the red asterick).

So instead of this (your original):

Author, “Title,” Journal, |Vol. Volume, |Date |Year, |p.^pp. Pages|​(in Language)|.

The template is changed to this:

Author, “Title,” Journal| ,* Vol. Volume| ,* Date |Year, |p.^pp. Pages|​(in Language)|.

To edit the output style template, go to the EndNote toolbar, select EDIT, OUTPUT STYLES, EDIT [Name of Style].  Then in the style’s window, locate “Bibliography” in the left column then click TEMPLATES.  Locate the desired template (use the “Reference Types” pull-down menu), modify the template then click to close the style window.  You will be prompted to save the changes - which will be saved as a “Copy” unless you indicate otherwise.  If you save the output style as a copy, don’t forget to change the style setting in both EndNote and MS Word to reflect using the style “Copy” otherwise the changes won’t be visible.