"Update citations and bibliography" does not update reference list

Hello everyone,

A document that I have been working on has an Endnote library file (.enl) attached to it. Today I have made some changes to the library file and then clicked the “Update citations and bibliography” button in Word to make the changes visible in the reference list at the end of the document. However, the reference list stays exactly the same, without the entries changing to reflect what is now in the Endnote library. Why is this happening?

Also, how can one control which document a given Endnote library is attached to? It could be that, for some reason, my library is not attached to the document anymore, and perhaps this is why no changes are made when I update citations in the document. 

I use Word 2007 and Endnote X2 Bld 3210.

Thanks in advance for any help!

This shouldn’t be too complicated for anyone who’s used EndNote for a while - I’d appreciate any suggestions as to what I might be doing wrong here.

Try unformatting and reformatting the references in the document. 

Editing a reference, particularly editing the First Author, the year, or the deleting the original record and replacing it with a new one (new record number) - will cause endnote to think the inserted reference is no longer matching a record in your library, and it will revert to using the information from the traveling library.  If it is a one-off reference -deleting the reference, and reinserting it, should also fix the problem – but to hit them all- unformating and reformating, will force endnote to ask about a reference that no longer matches exactly. 

During the reformat process make sure to reengage the CWYW from the third tab of the dialogue menu. 

1 Like

Thanks Leanne, I’ve unformatted and reformatted everything back again, but the latter operation brings up a “Select matching reference” window for each individual in-text citation. This process of reassigning references to in-text citations is not only painstakingly slow (with hundreds of in-text citations in my document, this whole thing would take hours) but also leaves some in-text citations in their temporary form, with no corresponding reference presented for them in the lower (white) part of the window.

This being said, however, this workaround seems to fix the problem of the library edits not being reflected in the references list. I just wish there were a faster way of doing it, because I really would not want to spend hours doing this chore just because of an Endnote bug…

I don’t think this is an endnote bug. This means you have a completely different library than you used to create the manuscript? If this is the case, then none of the changes you make to a different library are ever going to be reflected in the formatted manuscript.  Can you find the original library?  It would be the best option in the long run.  If the records aren’t in the library, it is kind of hard to match?  If you switched libraries in the middle, you can format with two?

1 Like

I don’t think this is a different library, because the changes that I made to it were visible in the references list after reformatting everything.

It wouldn’t have made you replace each reference if it were the same library.  if you unformated and reformated with the correct library, it would zip thru the reformatting process. 

1 Like

I see! There may have been a mix-up then, I’m not sure. How can I see what library (.ENL file) a certain Word document is associated with, and also vice-versa, how can I see to what document a given library file belongs to?

I am not sure how well it works, but the last tab in the format dialogue is “libraries used”.  When you “edit  citation”, more… it should list the library the reference came from at the bottom of the record listing, but in my experience, it always says “traveling library” there. 

If the correct library is open, placing your cursor in the formated citation (not in the reference list at the end) allows you to choose a tool “edit library reference” which will open the reference (or references, several in citation) for editing in the open library.  However, if a matching record is not in that library, it won’t open anything (and doesn’t seem to give an error msg either!).  It doesn’t let you edit the ‘travelling library’ version. 

If you don’t know which library a specific record came from, check to see if  you recognize the name of a different library in the “format” dialogue and search for it on your hard drive.  BTW-- Unformatting the document is likely to erase that information!

Since I always use the same library, I don’t delve into all this, very often!

1 Like

This is all becoming very complicated… In the Edit Citation-type dialogs, what I have written below is “Traveling library”, as you said. Actually, I think I used to “export to traveling library” command some time ago, since I had lost the file containing the original library. I think this is when all the problems began, because EndNote does not allow you to clearly define what document goes with what library.

I tried fixing all the in-text citations one by one (after unformatting/reformatting), but it is just too much time - plus, since many authors have more than one paper out in the same year, the suggestions that EndNote gives me in the “Select matching reference” windoware not enough so I have to go and find which is the correct reference.

What is strange is that, if I add a new reference to my library, and then use a citation to it in-text, the new reference is added to the list at the end of the document. Therefore the library is not “unlinked” to the document, but  - and this is really the problem - the existing references are not updated in the list when I edit them in EndNote. I am at my wit’s end…

Could someone please help on my last post? I am really confused why changes in my library are reflected in the references in list when I *add* a new reference, but not when I *change* an existing one. What can I do to make it also react to library edits of the latter type? Many thanks for any suggestions.

I have had this exact same problem. I have even deleted the citation in the text and replaced it, and it still wont update the change!!! I have unformatted and reformatted and it still wont update the change!!

It is a real problem. Can anyone help? It is really a very strange problem. It is as if endnote has created a memory and just can’t change it in the reference.

Are you sure you didn’t use it more than once in the document? It does sound very strange, if you unformated and reformated.  What version of Endnote and Word are you using? After unformating - can you remove all fields in Word (use a copy) (Crtl A then CTRL+Shift+F9), then try reformating.  The “non-matching” reference should come up to replace with the edited reference.  


very unfortunately I have the same problem as above: I tried all of your suggestions in order to update bibliography and citations after modifying respective fields in my Endnote Web library… it is not working at all. 

It does seem a debug in Endnote Web… Any news on the topic, please?

Just go to control panel and “repair” the program.  Don’t fool around with all of these other options.  That’s what worked for me.

Not sure you can “repair” endnote’s web version.  I am not sure how endnote web works with assigning/linking records to their in text temporary citation.  What does the temporary citation look like?  does it have a record number and does the online version have a matching record number?  I work pretty exclusively with the desktop version.  I would ask Tech support as they may have a way to relink a document to a libary.  

thanks! Control panel/ repair program worked for me

This is a bug, and evidently an old one. It has happened to me also and I’m not using a travelling library.

This shouldn’t be too complicated for anyone who’s used EndNote for a while - I’d appreciate any suggestions as to what I might be doing wrong

Word with Endnote always has a traveling library, which it reverts to if it can’t find the matching record in your open library.