Word 2007 - Endnote library changes don't update

Hi all,

In checking my references in a Word 2007 manuscript I find various small errors. Fine. I correct the references in the Endnote X library that I used and use the “Format Bibliography” command in the Endnote Add-in menu within Word.  The changes DON’T show up.  The only way I can get them to “take” is to delete and then re-insert the reference.  There’s got to be a better way.  I couldn’t find any info in the Endnote help file, although it seems like an obvious thing everyone would need to do. What am I missing??

Frustrated and confused.

Just curious but have you checked MS Word’s “Add-ins”*  to see if the 3 files associated with EndNote appear in the Active Application Add-ins list?  The 3 add-in files  that should be listed are: EndNote (Cwyw Citation Recognizer), EndNote Cite While You Write, and EndNote Cwyw.dotm.  If one or more are missing, look at the “Inactive Application Add-ins” section, locate and select the add-in, then click the GO button.  Then click OK to close the box.  Return to your MS Word document and try updating the citations/references again.

If not, you could: 1)  try uninstalling and re-installing EndNote (backup your .Data folder and .enl file); 2) contact Tech Support

*In MS Word, click the MS Office button, select “Word Options”, then “Add-Ins”.

I suspect this isn’t a problem with your Endnote installation, but a problem with the kind of small changes you are making to your references.  If those changes affect the First Author surname or the year, these are each a part of the main elements that need to match exactly between the inserted field containing the citation and the record in the library.  If they don’t match, Endnote assumes it isn’t in the library itself and resorts to the information in the “traveling library” in the document itself.  

To avoid this, you should try the “edit reference” when you want to change/correct a specific reference in the library.  Of course if you used it 3 times, the other 2 still might not match (and you might get it in your bibliography twice).  To catch them all, the easiest way is to unformat the paper, and reformat (reengaging CWYW at that time from the third tab) and Endnote will prompt for those references that don’t exactly match a library entry, and you can replace it from the “closest” list provided.  

I am having this same problem. So this solution worked?

Leanne, I had a go at your suggestion but coudn’t get it to work.  Have I understood you correctly?

If I just go ahead and change *some* details in the library, it will update, but critically, if I change the 1st author’s surname or the date, it won’t.  The only way around this is to highlight the reference in the document, then click, ‘edit library references’ and change it there.  Then it should update in the document?  Should I have to click something to launch this update process…?

OR - I can highlight everything - appl-A, and then click the ‘unformat citations button’…?  But how do I then turn on CWYW in order to get it to pick up the references again?

Sorry for my density…!

First, what version of Endnote are you using?  X4 is better at recognizing a change to those primary fields, and it might just work fine, but if you have a slightly older version of Endnote, then you should be able to update it as you summarized (in first paragraph). 

If it doesn’t work, the second paragraph will.  You turn CWYW back on by running the format paper/bibliography manually.  I am not exactly sure how it works in Word 2007, but help in the program says that in Word 2007and 2010 : On the EndNote tab, in the Bibliography group, click the bottom corner arrow.  Then go to the second “Layout” tab and enable CWYW.

I have the exact same problem

Word 2007

Endnote X3

I have hundreds of footnotes - just changed a couple of the author name surnames in Endnote itself

Not updating in the word doc

Couldn’t understand what solutions were being proposed here…

When you change the Author name, X3 uses that as a unique identifier in combination with the record number, to ensure you aren’t inserting the wrong record (say you have a different library open) - and if it doesn’t find the exact match, it uses the information it has it the so-called “travelling library” which is embeded in the document.  

You need to find and replace those citations.  The easiest way is to select all the footnotes (so I think you need to be in footer focus) and unformat and reformat them.   In X3 I am not exactly sure if I remember what that unformat tool was called, but make sure you have  the paper saved and then on a second copy, Find the unformat tool on the word endnote toolbar (not remove fields or codes, but just unformat.  They should now look like this in the footnotes {Author, Year #rec.no}.  Reformat or update or Format Bibliography, and the few citations that no longer have a match in your library (those you changed the author name of) will pop up and ask you to select the corrected version from your library.  

Now it should be fixed. 

Could it be because of the Windows updates? I am having a similar problem and NOTHING works. Sometimes, Windows updates messes everything up, so Im thinking this is what has happened.

It’s been driving me mad for DAYS! :womanmad:

I am using X5

 What do you mean nothing works?  Is the CYWY enabled? 

I tried to follow this, but in Word 2010 the layout tab had only type and paragraph options.

I am having this problem too. I changed the reference type from book to journal article in one of the records. I’m still getting the book format in the bibliography. Whatever I try, I get a ‘command failed’ message.