Windows cannot find file error - Vista Home Premium SP1, EndNote X2.0.1, Word 2007 SP1


I am running Vista Home Premium with SP1, Endnote X2.0.1, Word 2007 SP1. 

After installing Endnote to the system, I noticed when I tried to double-click open a word document I received the:

“Windows cannot find file ‘c://filename’” error.

 I have exhaustively looked through Vista forums, Microsoft knowledge base, Word forums, and the this forum. I’ve checked other forums like Experts-Exchange, etc. 

Some people had issues with permissions, which resolved the issue.  Some people had issues with file association, which would resolve it.  Mine is none of those.

Some of the knowledge base material on Word suggested deleting and resetting registry data for Word, which I did, to no avail.

I then deactived the EndNote COM Add-In “Cite While You Write” - and bingo! The error is gone.  However, that means I can’t access that COM Add-in which is a major part of the application.

Does anybody else have a similar problem, and what did you do that worked?   I have tried isolating Add-Ins and re-adding and removing ones to see if there are ones that are incompatible with EndNote COM.  But even when I have everything removed, and ONLY the EndNote COM, I get the error.  Now, it’s strange because not everybody encounters this - so what gives? Is there a conflict in the registry some where?

I have a similar problem. I use Word 2007, EndNote X2 and Windows Vista Home Premium. I get the message “Invalid Class String” when trying to connect to EndNote X2. Tried reinstalling word and EndNote, No success.

I contemplate upgrading WV Home Preium to Business Edition. I heard it handles users and account better.


There’s a fix to the Invalid Class String problem on the Endnote web site here:



Message Edited by cobrien on 12-02-2008 03:28 PM

I encountered the same problem with the latest OS (windows 7, build 6956) coupled to word 2007 sp1. After Endnote X2 installed,  I cannot open any word documents but receiving the error “windows cannot find file ‘C://filename’”. The problem seems to be different from the one of invalid class string and the method provided by FAQ13 did not work. 


I’ve exactly same situation. I’m using Vista Home Premium SP1, Endnote X.02, and Word 2007. I’m also receiving the same message “Windows cannot find file ‘c://filename’”.

Not only this error, but also I’m having trouble with track changing. When I open the reviewing pane of the track changes and click any of the changes made by somebody who also edited my paper with 2007, I got error message saying “Unspecified error” from Endnote X. The most annoying thing is that the error message won’t go away even though I hit the OK button again and again. Actually it goes away, but just comes again and don’t let me do anything else. Really annoying.

The third error is “The parameter is incorrect”. I’ve this error when I try to exclude author from the citation or do anything with the citation. I still couldn’t find solution for any of those errors.

I’ve tried to disable Add-ins; didn’t work. Uninstalling and re-installing everything didn’t work. I’m not really familiar with technical issues so I really didn’t dare to poke registries. So, basically now I’m giving up and trying different free similar softwares. 

I forgot to tell that only solution I’ve found so far for my problems is diabling Endnote add-ins. That’s all. But yes, I agree that I can’t cite while I write. That sucks.

I fixed my problem, it may be helpful to you guys.

Please keep office 2007 and Endnote installed in the same system drive as windows OS (disk C:/, usually). 

Good luck. 

Message Edited by trustchan on 12-25-2008 05:18 AM