X3 + Windows 7 : installation halt / crash when "Installing Export Helper"

Hello, I’m trying to install X3 on my Win7 Professional laptop. I already had it up and running for months. But I had to reinstall Win7 and now X3 installation crashes and there’s no way I found to successfully install. No matter what I choose to install it gets up to “Installing export Helper” (I guess thats the Research soft direct export helper program listed in Win7) and then nothing… When I kill the installing tmp-process I geut error 1722 which ist telling me that a programm run as a part of the installation has failed installing. Well, when I get to the crashing time I see something switching focus of windows und the waiting clock of windows - but what ever happens then prevents the installerfrom progressing. I have tried X3 and X301 - both crash the same way… Any ideas would really be appreciated. Thank you.

  Forgot to mention that this Export Helper is actually being installed and showing up in the installed programs list, but apparently it’s success ist not reported to the main installation which simply keeps waiting for an answer. I managed to see an installer icon in system tray when the helper is installed which vanishes in seconds. I tried to install with the msi-package now - some result. Funny that I tried to install X2 … no problems at all. How come the old version has no probs? I found the following error recurring:

Fehler beim Generieren des Aktivierungskontextes für “C:\Program Files\Common Files\ResearchSoft\Cwyw\13\EndNote Cwyw.dll”. Die abhängige Assemblierung "Microsoft.VC90.MFC,processorArchitecture=“x86”,publicKeyToken=“1fc8b3b9a1e18e3b”,type=“win32”,version=“9.0.21022.8"” konnte nicht gefunden werden. Verwenden Sie für eine detaillierte Diagnose das Programm “sxstrace.exe”. Event: 33 SideBySide



Well, I got an answer that the reason might be PCTools Spyware Doctor. At that time I had PCTools Threatfire installed - even though I disabled it during install. Yet it may have been the reason but I can’t proove that at the moment as I reinstalled my laptop and won’t install Threatifre again. But I hope this hint will help other people.

Message Edited by phoenX on 02-16-2010 06:02 PM