X5. How to get in-text citations with page numbers only?

In X5 the formatting for in-text citations has been changed. It’s now a drop-down list. There are several very annoying problems with it:

  1. I don’t seem to be able to exclude author AND year. I can only do one of them. This is very, very poor as I have been using this quite often for repeated citations in a paragraph where I refered to different pages in a reference.

Is there any way to exclude both? If not, I will have to go back to X4!

  1. Having a drop-down list takes away from the good visibility of options that was there before. I don’t want to click on a drop-down box to get different options!

We’re planning to have an option to edit a citation and exclude both the author and year with the X5.0.1 update. I’m really sorry the drop down menu isn’t ideal for you, but the functionality will be restored asap.