Adobe Digital Editions File Attachments are crashing Endnote x4

I downloaded a book from Google Books that was only available in Adobe Digital Editions [ADE] format - there was no PDF. So I created an Endnote record for the book and tried to attach the ADE file in the File Attachments field, just as I normally would with a PDF file. This is what happens:

-when the Endnote record is open, and you drag the ADE file into the File Attachments field, nothing happens: no file icon appears.

-but when you try to save and close the record, Endnote crashes.

-when you re-open Endnote, the little paper clip is visible for the record in question if you view it in the Library Window (provided you have it set up to show that field). You can even click on it there to open the ADE file. But if you open the Endnote record itself, there is still no file icon showing in the File Attachment field. And then when you try to close the record, Endnote crashes.

Any thoughts? Thank you in advance. If you need screen shots let me know.

This is most definitely something to report to technical support. The file attachments field should take anything so this behavior is something they’ll need to look into.

Thanks - will do!