APA style when required field are missing


I’m helping a customer with a document using APA and some reference types are displaying references with double spaces. One example is the government document reference type. If there is no report number in the report number field the template seems to expect that field and to add a space before it. If we add a made-up report number the formatting is OK. Also, I found that I could change the space before (Report Number) to a diamond (Link Adjacent Text) and that then the double spaces don’t appear, however, I had to then add a period after the title in the reference data in the EndNote liberary. (These strategies were not all entirely my own!)

Does anyone have recommendations for what to do in this kind of case. We were seeing problems of this type (the double spaces) with the following reference types: government document, hearing, electronic book, and web page.

These were my first try at writing the instructions for this as well as mention of an alternative.

I talked with EndNote technical support and I found that it appears that the way the APA style is represented in EndNote, it seems to be expecting certain of the data fields—for example, the record number field in a government document. So, if that data is not in the reference, it results in there being an extra space. Technical support showed me how to avoid the space, however, it will require a little editing of the style.

In case I don’t hear from you today, let me mention what these changes are.

First we go to EndNote + Edit menu + Output styles and then edit the style you are using.

Under Bibliography click Templates

and for example, view the Government Document reference type

The template originally had  Author (Year)| Title|. (Report Number).| at the start (I may not be including some of the punctuation)

The change we made was changing the space in front of (Report Number) to a diamond

Now, the space is represented in the template by a dot midway within the line (so sort of parallel with the middle of the R).

We want to replace that dot with a diamond which is added by clicking the Insert Field button at the top right of the style editing window (same window as shows the templates) and then clicking “Link Adjacent Text” near the top of the list

One way to do that is to click right after the dot before (Report Number)  and before the first parenthesis, then add the diamond (using Link Adjacent Text) and then backspace the dot.

Then the problem is that EndNote doesn’t automatically add the period after the title, so in the record for the reference that was not displaying correctly, add a period after the title in the record in the EndNote library.

When we went through these steps, it worked for the reference I was working with and didn’t seem to cause the other government document references to be affected (though I did not check all). Technical support thought that the method would work.

Another option is to remove codes in the Word document and then to directly edit the document and remove extra spaces that way. If you do that, it is strongly recommended that you make sure you have a copy of the most recent version of the document with codes as well as the copy with the codes removed that you then edit. Then if you do have to do any more work with the document with EndNote, at least you have the most recent version possible, though you’d have to do all the additional editing steps again (such as removing the extra spaces). There is a built-in way in EndNote to do this, however, technical support mentioned to me that there is another way to remove the codes that may be useful. The built-in way can conflict with Word templates (such as the Thesis Office’s Thesis template) and advanced formatting in Word. The other way may not conflict in the same way or at all. The steps of the other way to remove codes are

Save the document with EndNote codes

Save as a second version (to be used to remove codes on the second version)

In the second version press Ctrl + A (this selects all the document, highlights it)

Then press Ctrl + 6

That document should allow direct editing, however, EndNote cannot be used with the document after codes have been removed.

Have a nice day


This is a whole lot easier, if you attach the edited style.  It should be in the mydocuments/endnote/styles folder. 

There is quite a lot of pretty clear information about those two special characters in the “help” in Endnote, link adjacent and forced separation.  If you go to the Help (F1) you can search for Special Formatting Characters in the index tab of the help. 

Looking at the Government template, there is another change you need to make, to avoid the punctuation error you mentioned.  That period before the separation character following the (Report Number) should be after it, to avoid having to add the period to your title.  The way it is set up, the period also disappears when the “report number” field is empty.  Also, I would get rid of any extra spaces infront of `Retrieved from ?

All spaces apart from those that are apart of the field name, should be replaced with the link adjacent character. 

Author. (Year)|. Title|. (Report Number)|. Place Published|: Publisher| `Retrieved from URL|.

@jfullert wrote:

Does anyone have recommendations for what to do in this kind of case. We were seeing problems of this type (the double spaces) with the following reference types: government document, hearing, electronic book, and web page. 


You seemed to have resolved the problem. Adjusting the portion of the government document template by inserting a link adjacent text character (“diamond”), and moving the period after the forced separation is correct:

Author. (Year)|.◊Title|.◊(Report Number)|.

Link adjacent text helps to “connect” fields and/or punctuation items together and has broad application. So in your example if the report number field is blank/missing, both the field (Report Number) and the preceding period will drop out. The period at the end (following the forced separation “vertical bar” character) now “drops in” and will appear after the report’s title. Using EndNote’s special characters assists in creating and modifying templates.  Info is available by going to the EndNote toolbar and selecting Help > Search for Help On, then typing “Special formatting characters”.

The underlying concept for the sample template fix above has application to other reference types (i.e., government document, hearing, electronic book, and web page) but will need to be adjusted to fit the fields used in the given template.  

Addressing template fixes is best pursued first in EndNote as once the problem is addressed, corrections will be automatically applied to current and future entries. Removing field codes in the MS Word document is an option of last resort as it deactivates the links to the EndNote library.

Thank you both for the notes. I appreciate them! I was hoping (had been thinking) that the templates were defined so that they would work OK no matter how few fields had data.

Just talking about the sequence of Title and (Report Number) is there no usual way to have the period tied to Title and the following to display correctly whether or not there is a Report Number?

Right now, I have a period added as the last of the title in the reference data.

I’m sorry that I presented such difficult reading material :slight_smile: I was thinking this morning before reading these responses that as a support person for EndNote at my university I should probably learn how the special characters work in style editing. I’ve heard what seems to me quite different explanations for them including that the “forced separation” line should be used in pairs positioned somewhat like parentheses, though others have said that is not needed. I will plan to read the program help (and maybe check the pdf, though probably the same, and the online FAQ’s and Knowledge Base).

Have a nice day