attached pdf issues when importing .ris into X6

I have been trying to export some references with attached pdfs from Mendeley desktop into Endnote X6 (win7 OS).  I’ve tried exporting as endnote .xml, and then importing that file from endnote, but the pdfs are not getting copied into the pdf subfolder in the data folder.  So the references have the broken attachment message: "The following file could not be opened. This may occur for a number of reasons including, but not limited to: the file is corrupt or the relative link was deleted.

File D:\References\temp pdf import.Data\PDF\Cothran, Brown, Relyea - 2013 - Proximity to agriculture is correlated with pesticide tolerance evidence for the evolution of amphibian.pdf"

I do have the “copy new file attachments into default folder” option checked in the preferences window.  I have also tried exporting the references as a .ris.  When I import that file the absolute links to the pdfs are maintained, but no new relative links are created.  I’d like the relative links to be created so that I don’t end up with pdfs associated with one library in two different folders.

Any ideas how to make this process work better?



If the links are there as absolute (mind you- I have never tried this, so if they are URLs and not attachments this won’t work) then you can ask Endnote to convert Absolute to relative and it will copy the files to the subfolder structure.  This option in X7 is under references, file attachments> “convert to relative links”.

That worked (converting to relative links).  I’m leaving the post open (not accepting your solution as a solution) in hopes that someone has an idea about how to get the files imported as relative links directly.  But thanks for the solution!