Author-year citation

When I select the Author-Year template, it looks like author(diamond)(superscript)bibliography.number (the diamond and superscript are shown - not written). However, when I insert a reference according to author-year, there is a square bracket added to the right of the reference number. 

How can I remove this since it does not show up in the citation template.

I’m using X6 on Mac.

That is a very strange thing to appear in an Author-Year Template?  Can you give more details on how you created this?   Can you provide a screen shot of the Citation template?  I provide a screen shot of a typical Author year template.  


OK, I started with an existing template being “Comp Thera Clin Pract.ens” for the journal Sleep Medicine Reviews and changed the style according to the requirements of SMR. I’ve attached the modified one.

Some elements I did not change, others I did like the “Citation-Author (Year)”, see screendump.

You can see there is no square bracket in the template although there are 2 in the template “Citation”.

I’ve added a screendump of the table I’m trying to get in the right format for SMR. From row 3 it is what I made of it hardware-wise: I typed Author et al and inserted “Citation”. I learned that it could be done otherwise by inserting the “Citation - Author (Year)” so I did 2 things: in row 1 I just deleted the existing plain text and changed the appearance of the bibliography number into Author-year, but then a square bracket turned up at the right hand side. So, I completely deleted the plain text as well as the bibliography number in row 2 of the table and reinserted the citation via the “Citation - Author (Year)” template, but identical result.

Pretty desperate right now because of submission deadlines. Would appreciate your assistance.

By the way, I learned on internet that the Mac version has less editing options as to fonts - superscript etc than the Windows version on the level of these templates. I did notice that the screendump you’ve sent me indeed shows different options in Windows than on Mac. Is this still the case for X7, otherwise I upgrade to X7 if then my problems are solved?



Comp Thera Clin Pract SMR.ens (13.6 KB)

On a PC version of EndnoteX7.2 I used your output style and got the two citations as shown in the screen shot.  I inserted them normally, and then converted the one in the table to the Author (Year) format, and got no close bracket. Do you not want the citation italicized?  If not – the version attached, I removed the italics by selecting and ctrl+i (i for Italics).  Again, don’t work a mac - so can’t view the font options there.  If the mac version is misbehaving, perhaps a mac user can test this? 

added in edit, the modified no-italics version is attached too.

Comp Thera Clin Pract SMR author-year altered not italics.ens (13.5 KB)

I tried these ens files, but with identical results, then I upgraded to EndNote 7.2, and all is working well now and I was able to make my submission.