Bibliography displays dash instead of author for some references


I’'ve had a weird problem on my thesis where the citation is fine, but in the bibliography the reference just has a — in stead of the author. It’s happening on three of my references, and they (as far as I can tell) have been inputted in exactly the same way as the other 50 or so. I really can’t figure this one out even with quite a bit of experimenting so any help would be greatly appreciated.


I am assuming that this occurs when the first author is repeated and is a setting in the style.  What style is being used in the maunscript (in the fomat paaper options) and is this by design for your publication style?  Attach your style to a message here and check the requirements.  The option will be in the relevant section of the style settings.  (Author listing).

1 Like

Does the “—” appear when the references happen to be by the same author(s) - also known as “repeated authors”?  If so, it sounds like the “Replace repeated authors with: —” option might have been mistakenly selected. Check/change the “For Subsequent Works by the Same Author” setting located in the “Author Lists” option on the output style’s Bibliography setting":

  1. Go to the EndNote toolbar, select EDIT, OUTPUT STYLES, EDIT [Name of style].  This will cause the output style’s main window to pop-up.

  2. In the left column of the style window, locate “Bibliography” and click to select AUTHOR LISTS.

  3. On the right side, bottom, locate the selection labeled: For Subsequent Works by the Same Author.  If the last option is selected (Replace repeated authors with: —), change to: Print the author list as defined above.

Close the output style window.  If prompted to save the changes, note that they will be saved under a new file name that includes the word “Copy” (unless you manually delete the word).  If you save the changes as a copy remember to change the style selection in EndNote and your word processor to reflect the proper output style name otherwise the changes won’t apply to your document.

1 Like

Absolutely that has fixed it. Thanks so much guys, it probably seems trivial but it was causing me some grief. I couldn’t see the pattern as the authors listed perfectly except for where they had contributed chapters of the same book.


I’ve been trying to get rid of hyphens in MS WORD 2013. There aren’t any settings described above. So if anyone wants to repeat authors in bibliography - go to your appdata folder. Eg: C:\Users\<name>\appData\Roaming\microsoft\Bibliography\Style\ open ISO690Nmerical.XSL  and find these four lines:

<xsl:when test="/b:Bibliography/b:Source[position()=$prevBook]/b:Author/b:Main = b:Author/b:Main">
<xsl:if test ="string-length(b:Author/b:Main)>0">
<xsl:call-template name="templ_prop_ISO690_SameAuthor"/><xsl:call-template name="templ_prop_Dot"/><xsl:call-template name="templ_prop_Space"/>


And thats it.