Citation numbering problem

When citing reference as the bibliography numbers, the dash (-) between consecutive numbers cannot be shown.  So, some weird number came out.  Has anyone met similar problem and know how to fix it? Millions of thanks

Have you tried another format number style to see if it specific to the style.  Attach your style and someone can look at it to see if there is an error that can be located.

I have the same problem, with a selfmade (adapted) output style. Other numbered styles work as they should. I have attached my style, if anybody could have a look at it?

Cat Style v1.ens (13.8 KB)

@cat wrote:

I have the same problem, with a selfmade (adapted) output style. Other numbered styles work as they should. I have attached my style, if anybody could have a look at it?

Could you clarify your statement by providing an example of what the proper bibliography entry should be and what your output style is producing?

I would like to have consecutive citations in the text as e.g. (1-3), but I get (13).

Thanks for the info, Cat.  Testing your style does result in a missing hyphen separating the citation numbers. But I suspect there may be a problem with either the original file upon which you based your modifications or your current file. This is because I tested the “Cat Style” modifications (just for the Citation templates) by taking an original “Number” output style and changing the settings to match your settings up to and including the Citations section.(I omitted modifying the bibliography, footnotes and remaining sections since the key issue focused on the citations.)

In testing the new output style, the hyphen now appears between the consecutive numbers (see attached image and modified output style file). So this may suggest something wrong with either the original output style file or your resulting modified file.  

Reconstructing your Cat style modifications with a new “base” output style file might address whatever mystery underlies the missing hyphen.


NumberedStyle_Redone as CatStyle_Citations.ens (14.6 KB)

1 Like

Thank you very much! With your reconstructed file the hyphen appears in my document, too. So maybe my mistake was not to use a “Number” output style…

I changed the remaining settings in your file according to my requirements, and everything looks fine now!

Glad it works and you’re on your way!

Best,

CG