EndNote X4 and Microsoft Word 2010

I’m working in a large document, my dissertation, and I keep having problems. Each time that I want to insert a citation or edit it, appears Endnote is waiting for user information. Please switch to the EndNote program. And in the Endnote Program: This action cannot be completed because the dissertation Microsoft Word program is not responding. Choose Switch and correct the problem.

It is very frustrating!!!

I got support and i resolved. It was about damaged field codes. Thanks

Can you please tell me how could you solve this? I’ve got the same probleme here! Thanks anyway

Could be caused by many things and the usual fix if it caused by a field code corruption, is to unformat the citations/bibliography to curly bracketed state, do a quick scan to see if any refs are still in regular parentheses, reinsert those, select all and remove field codes, reformat paper/bibliography (and  turn CWYW back on). 

More details about how to do that are in this FAQ. If that doesn’t work, the best thing to do is to contact their Tech Support.  Details about that are on the endnote website. 

I found this thread through Google when trying to troubleshoot an annoying compatibility issue betwee Word 2010 and EndNote X4. I created a rather large document in a previous version of Word and EndNote X3. I then needed to upgrade MS Office for some reason, and ended up also having to upgrade to EndNote X4. However, I’m now experiencing the problems outlined in the opening post. I tried the ‘solution’ (not really a solution, more of a hit-and-miss workaround) quoted above, but it doesn’t make any difference. On inserting or modifying a reference in this document, I still experience lockups in Word, with Endnote complaining that Word isn’t responding and asking if I’d like to ‘retry’ or ‘switch to…’. EndNote prompts this question anywhere between 5 and 20 times for each reference I insert or modify, effectively breaking my workflow with 1 to 2 minutes every single time.

Needless to say, I’m fed up with this. After several years of sluggish performance, compatibility issues and small annoyances in several versions of EndNote, I’m almost ready to transfer my citations database to some other application and uninstall EndNote altogether. The only reason I’m sticking to EN for the moment is that I’m not looking forward to screwing up my citations database, nor the document I’m working on.

Does anybody have any specific clues or paths to a solution for this problem (other than contacting tech support)? Or does anyone have a good alternative to EndNote that can handle imports of EndNote databases?

Since you seem so resistant to call tech support who are there to help you, you are stuck with our suggestions. 

I would still also recommend cleaning up any field codes it the document, if it a document specific phenomenon.  Do new documents show the same behaviour? If it happen even on new documents, then, I would lalso ensure that there are no residual toolbars from previous versions of Endnote, that no other versions of endnote are installed, and would then uninstall Endnote X4, clean out the registry of any reference to ISI so you start with a clean install and make sure you update to the X4.0.2 patch.   

Leanne, thanks for your suggestions. I’m hesitant to call tech support because in my experience, it’s an inefficient way to solve a problem.

I tried removing remains of previous endnote versions (indeed, there appeared to be something of X3 left), unformatted the document and copied all text to a new document (need to reformat all captions and other fields *again*, luckily this is only a 100 page document), and updated X4 to the latest build. The result is that when inserting a reference, I now get a nifty little status bar that shows what EndNote is doing. This status bar takes about a minute to reach 100% in this document, and then in 50% of the instances it stalls (stays at 100%, but doesn’t disappear). If that happens, I have to switch to the EndNote window to deal with the inevitable error message and choose either ‘Retry’ or ‘Switch to’. The upside is that clicking either one does make the dialog disappear and I can instantly go back to Word.

So this has sort of helped, although inserting references is still a hit and miss affair and a phenomenally slow process to boot, but I guess I’ll just have to live with that.

Thanks again for your swift response!

PS: performance in new (small) documents is much better. The trouble I’m having is with a 100 page document with about 200 references. Most of my colleagues also complain about EndNote taking ages to insert a reference in a document of that size, so I suppose it’s inherent to EN’s architecture.

Hi, this happens to me as well with Office 2010 and Endnote X4.0.2 (yes, clean installs.)

Honestly, it looks like a timeout-issue in the communication between Word and Endnote because something now is much slower with the 2010/X4 combo.  Specifically, it usually hangs at the “Updating hyperlinks…” stage…

A quick “retry” in the EndNote X4 interface makes it complete the process, though.  

Some other issues that might be helpful in resolving this issue:

  • The document is only currently 50 pages with only about 160 references.  (It may triple/quadruple in most respects over the coming months.  I am thus seriously concerned if this issue is not fixed soon… )

  • I have for the last decade worked with much larger documents and reference lists in earlier versions of EndNote and Word, and almost never experienced these problems (when such a time-out very rarely happened, it was usually due to Word crashing rather seriously)

  • I have of course turned off automatic update of references to deal with this (this is, however, quite annoying when you need to specify page numbers, as then the citation of course needs to be a proper Word field first)

  • EndNote X4 seems in general quite slower than earlier versions in dealing with large reference lists in documents (it should be factored in that those earlier versions generally even ran on quite slower computers…)

To me, an intermediate quick-fix would be to give EndNote  a (much) higher time-out value for as long as the Word-side of things is quite more time-consuming than before.  Ideally, the whole literature list should of course be built in background (yes, at the risk for the user interfering) - but I guess this is not possible with the current interface you use in building Word macros etc.

Hope you are able to identify the issue, because if this is a persistent issue with EndNote X4 and Word 2010, this is at least for me an unacceptable time-stealer calling for alternative solutions. I would really prefer not changing the citation manager in the midst of finalising my PhD thesis, though :wink:



@mastodon wrote:


 … so I suppose it’s inherent to EN’s architecture.

…which could also be affected by the computer’'s OS and speed.  Just curious but what’s your OS and processing speed?

@haakons99 wrote:

  • I have of course turned off automatic update of references to deal with this (this is, however, quite annoying when you need to specify page numbers, as then the citation of course needs to be a proper Word field first)

@you1 can specify the cited pages in an endnote citation as  {Smith, 1999 #24 @145-6}.

Thanks, very helpful.  I actually use the “suffix” field as I’ve found it to be more reliable with changes between output styles than the pages field - however, I saw that this can be referred by appending ", " instead of the @.  

Very useful.  As I now only need to build my literature list once per day, I can certainly live with this small 4.0.2 time-out glitch until it’s fixed… :slight_smile:

Keep up the good work and looking forward to your 4.0.3… :slight_smile:  (If I may: if you in addition to the time-out issue also manage to tweak down your algorithm for building the literature list towards the performance it had in the “old days”, that would be delightful for those working with large books, theses, reports etc…) 



I have nothing to do with Endnote! just a user like you.