Filter problem?

I’m trying to import citations from a certain journal into my data base. However, instead of importing I only get a window

Author: Name

Title: xxx


It only happens for that particular journal - how can I fix it?

Which Journal?  Not all of them provide an easy way to import, and those that do may have various output options to choose from, only some of which will import well into endnote.   

It is a Copernicus Journal… they do have an import link to Endnote.

In the meantime, I tried it on another computer, and there it works.- Why not on hte one computer?

Same browser?  See this threadabout the indosyncracies of the filter file opening with various browser I tried.  Did you ever install Zotero on the machine that doesn’t work?  If so see the threads in this thread. 

I checked - there is no zotero on my machine. And, yes, I use firefox on both machines.

You haven’t mentioned the name of the journal but did you check whether there’s an available EndNote filter for that journal?

When I have had this kind of problem in the past, I always try a different browser.  It is very likely that the wrong “choice” is the default for Firefox.  That is the main reason I referred you to the thread onthe idiosyncracies thread.