Multiple citation in Vancouver style


I’m a total beginner at EndNote, so the answer might be there right in front of me, but I’ve searched and can’t find it. Hopefully someone can help me!

I’m writing in Vancouver style, and when I have several articles in the same citation it ends up as (1, 2, 3, 4, 5) when I want it as (1-5). I’ve looked around in the Preferance menu, and I’ve searched here in the forum, but I can’t find the solution… I’m using EndNote X9 with Word on a MacBook.



It should be the in the output (Vancouver) style you are using – Edit, output style> edit “vancouver” under citations, numbering.  Out of the box, it should be set up correctly as in the attached.  If not, you should edit that setting, “save as”, to a new name eg Vancouver-update.ens) and then ensure your document is pointing to the newly named file. 

Thanks for the answer!

That box is already ticked in the settings. I’m already using a modified Vancouver style since I have a quote and needed to add the page number to a citation, so I added a field for that in the citation templates, this now called Vancouver Copy. I changed nothing more in the Vancouver settings. When I change to Vancouver, the qoute page disappears and the multiple citation turs into a range. When I go back to Vancouver Copy, the page comes back, but the range turns into seperate numbers even though I haven’t changed that setting. I also tried to untick the box, saved, and ticked it again. Same result.

hmmmm, yes, I suspect the cited pages field messes with the grouping, as it needs to be applied to a specific citation and cited pages in numbered formats are unusual.  What if you use “before” or “after” fields rather than the cited pages field?  How do the citated pages appear when you do use them in the numbered format?  Can you instead edit the settings for Author (Year) for the unusual ones where you need a cited page?  That might look like (Ref Bibliography number, page Cited Pages)

(Ref #, page X) 

What’s the solution?