Pdf annotations are not consistent


I hope this is not a duplicate.

I’ve imported some pdf in endnote. My annotation (highlights, comments made over the pdf with pdf X-change viewer) that have been made previous to the import, appeared just fine in the “Attached Pdf panel” : great!

but :

1) all annotation made on the pdfs with Endnote (“Attached Pdf” panel) are not applied over the pdf , meaning that when I open the pdf with any other software than endnote : they just don’t appear.

It seems that all anotation are stored within the endnote (library) and won’t change the actual pdf.

Is there a way to make annotation effective onto the pdf itself?

2) For all already imported pdfs : All annotation made with any other software than endnote won’t appear at all in Endnote. It seems that the Endnote doesn’t “refesh” the attached pdf. Is there a way to do that ?

Bonus : is there a way to browse pdf/references with Endnote and opening pdf with another software via the “attached Pdf” panel ?



Bonus question:  On a PC in X8,  “open file” shortcut is Ctrl+Alt+P or the little folder icon on the toolbar (which also tells you the shortcut keys -see attached image for what it looks like), or you can use the right click options, File attachments, open file.  

Thanks @Leanne for your answer to my bonus question!

For those who have the same problem as in my main question, this is the answer :

I  was not aware of this functionning of Endnote, but all PDF imported in EX8 are copied in a folder decided by EX8.

This means that the pdf you open, either by the method proposed by @Leanne or in the preview panel (or any other) is not the PDF you uploaded but it is the copy version.

This explains why all previously made annotations were kept, a new ones were not.

But : you can ask EX8 to use absolute link to your PDF , but be aware (1) that it will be expecting to always find the PDF in the same place (dropbox user be warned); (2) this will only be applied to PDF imported after you so the following action (already imported ones are still attached to the EX8-copied version). To do so : Edit → preference → URL&Links → “Copy new files…” at bottom : uncheck.