Problem: Suffix displayed outside of brackets

I used to be able to easily convert my unformatted citations to EndNotes in Word. I would simply enter the page numbers as suffix.

{Habermas, 1970 #1778, p. 86@@author-year}

would be converted to 

Habermas (1970, p. 86)

Now, it is converted to 

Habermas (1970), p. 86

Any ideas on how to get the suffix back into the brackets? I have not changed the output style. It is still “Sage Harvard”.

I’m using Endnote X7.4 and when I replicate your temporary citation example the suffix appears within the parentheses but omits the comma: Habermas (1970 p. 86)    

Try adding an accent before the comma (located on the tilde key on the keyboard), so the temporary citation looks like this: {Habermas, 1970 #1778`, p. 86@@author-year}

An alternative is to turn Instant Instant Formatting “on” and manually edit the citation through the dialog box. In the Suffix field delete “, p. 86” to clear the field then enter the info. Click OK.

I downloaded the Sage Harvard style and also didn’t see the issue you describe.  Did you alter the Author (Year) template in your version at all?  I have to say – it seems odd to me that the comma is included in the parentheses in the template,  as it comes out of the box.  But when I use it, it doesn’t show up there.  I know you are using the suffix not the cited pages field from your description, But I also tried editing the template to anything that made sense including Author (Year) and could not get the suffix to appear outside the parentheses.  

As it is in the template   Author (|, Year|: Cited Pages|)

Thanks for the suggestions. 


 Unfortunately adding a accent didn’t help, neither did the instant formatting.


No, I did not alter the style and the same happened with other styles.

I have now solved the problem by downgrading from X7 to X6.

I still wonder what the problem was, as I use EndnoteX7 and I don’t see this issue.