Problems downloading Endnote X4

I’m not sure if this is the right place to put this, but I can’t find an answer anywhere

I’m trying to download Endnote X4 to a mac with OSX Snow Leopard, and Word for mac 2008, but I get an error message:

(X) could not be saved, because the source file could not be read. Try again later, or contact the server administrator.

Ive, tried about ten times over the past week. This only happens with endnote, no other downloads, so it doesn’t appear to be a browser problem.

I’ve tried restarting my computer, closing everything, deleting history, pretty much anything I could think of, so if anyone has any suggestions, it would be much appreciated.

Thanks in advance!

Do you have service pack 1 installed on your computer? You have to have this before installing Endnote. I’m not sure if this will fix the problem but it would be worth checking.



Are you downloading: 1) using a direct connection to the Internet; or 2) through a network?

If the former (direct connection), you don’t mention what browser you’re using but have you tried a different browser to download the program?  If the latter (network), you should check with the system administrator as you may need access permission to download, read/install the EndNote program.

Also suggest you contact tech support:

I think I have service package 2 which might explain it, I had thought it just needed SP1 or above, but if it’s only compatible with SP1 that would be why it isn’t cooperating. Is it a good idea or even possible to download SP1 to replace SP2?

I’ve been using Firefox 4, and I’ve tried it with Safari as well, which didn’t work at all. If by a network you mean a wireless provider, it’s just a home wireless router.

I will contact tech support though, thanks