Pubmed import filter for EndNote X2

The Pubmed import filter that I have is not picking up the URL in the reference. I’ve tried downloading the new version from the EndNote home page but that hasn’t helped. Searching Pubmed from inside EndNote, using the Online Search facility, does find the URL, but my institution is on EndNote X2 and I don’t like the way Online Search now imports all the references directly into your library.

I’ve looked at the filter but I can’t see the problem, or the difference between the import filter and the connection file which does pick up the URL. Does anyone else have a Pubmed import filter that can pick up the URL correctly?


If you can’t figure it out (although someone here will be able to help there) until they can apply the patch at your place, just open a temporary library and use online, and copy and paste the references you want to your library, just like in the old days? 

Have a look at the file of records that you downloaded for filtering. Is the URL included in those records? As far as I’m aware, Pubmed doesn’t provide the URL in the download (MEDLINE) format. If Pubmed doesn’t supply it, EndNote can’t import it.

Thanks John and Leanne.

Looks like I might have to stick with the temporary library/cut-and-paste solution for the time being.

It’s annoying that I can’t get the URL when importing but the online search *does* add the URL. Presumably if the URL isn’t in the original Medline format the online search does some sort of automatic conversion - of the DOI perhaps?


We are in the same situation. I called Pubmed and Endnote more than 5 times regarding this issue and worked on it a LONG time trying to figure out how to import URL in endnote. We used to use Reference Manager and it will import the URL with the same pubmed_result.txt file. Finally I figured out Pubmed is using the plus the pmid# as the link. So if Endnote let us add text in front of the PMID and import it to URL in filter templete, it should work!. There is no need that the URL being in the pubmed output file. So I called endnote again. The answer of course is “NO”. I can’t add custom text in front of the field. So disappointed and frustrated.