Temporary citations not resolving

I have a sample document with this content in temporary citations:

Some researchers have said this {e.g.`, \Marsh1982b@287}. Others have said this also {BeitzelAERA2004}.

{Beitzel2010a,@@author-year} discussed something else.

In my library each of these references is uniquely identified.  When I “Update Citations and Bibliography” I am prompted to confirm each one (that is fine – I don’t mind that) but I cannot find any configuration of temporary citations to properly display the Beitzel2010a reference in “Author (Year)” format.  There are no matching references when I include the “@@author-year” specification in the temporary citation brackets, and when I search for “Beitzel2010a” the reference is found but does not display properly.  I have consulted the documentation on temporary citations but still cannot make headway on this.

After updating (and removing the “,@@author-year” from the Beitzel2010a reference) this is what I get:

What some have claimed (e.g., Marsh, p. 287). Others have said this also (Beitzel & Derry). 

Beitzel () discussed something else.

Notice that none of these citations contains a year, which violates my style (American Psychological Association).  My style is properly selected in Word 2010 when I run Update Citations and Bibliography.

Also, is there any temporary-citation code to indicate where the bibliography should go?  I need it to appear before the end of the manuscript (because of tables/figures following the bibliography).

Thank you for your time.

Have you inspected the formated references in the edit citation dialog box? It is much simpler there to select the options that you want.   I have never seen ones that look quite like this. 

Why are there a and b after the years?  If you need that - Endnote’s style should be adapted to do that automatically?  I would expect these to look more like this.  (note the comma space  before year).  How are you entering these temporary citations?

Some researchers have said this {e.g.`, \Marsh,1982@287}. Others have said this also {Beitzel, 2004}.

{Beitzel, 2010@@author-year} discussed something else. 

The way my APA 6th is set up, the a and b should be automatically produced and shouldn’t be in the temporary citation itself. 

Which version of Word, version of Endnote are you using?   

You can move the bibliography (I do it when it is small, you just need to make sure it is all selected) to the place you want it to appear, - and then it should be updated in that position.  (but it might reset to the end if you completely unformat the citations to the temporary version, and this may delete the bibliography field).  There is no way to specify it in the citations itself.  I am not sure if you could copy that “field” and save it and insert it manually?  I guess that would be worth a try?  I find it easier to just move it once.

Thanks for the response.  I am using Word 2010 and EndNote X5.

My citation values are actually BibTeX keys and they are unique across the entire library.  I am automatically generating this document from LaTeX, so I don’t have the EndNote record numbers available programmatically, thus the need for another unique identifier besides the EndNote record number.  Consequently, because I have several publications in 2012, I need unique identifiers Beitzel2012a, Beitzel2012b, etc.  So technically this amounts to {Beitzel2012a} being a search string rather than an {author, date} format.

The Edit Citation dialog is not displayed when temporary citations are resolved, so I have to go back into every citation in the entire document to add the year to the displayed format.  I was hoping someone could help me configure my temporary citations to get the year displayed by default instead of correcting each citation individually.

Yes, I can move the References list manually but again I thought there should be a bracketed equivalent that could be specified.  I guess EndNote is not as powerful as I anticipated.

Ah, there maybe a way to adjust this, but I am not sure.  In the preferences settings, there is a formatting setting that they put in for me about a thousand years ago, when I routinely typed in just the record number into the temporary citation.  The setting to turn off, is “omit Author and/or Year from formatted citation if removed from temporary citation”.  You will have to check, but I think that might restore the author, Year to the citations and I just don’t know how it will play with the author (year) @@ setting, without some testing. 

But try it!  and let us know?

Also,   I have a student who is interested perhaps using Endnote in combination with  BibTeX  and the LaTeX ediitor, so hints on how you approach this (maybe off forum) would be useful for my  discussion with him!

Wow – un-checking the “Omit Author and/or Year from formatted citation if removed from temporary citation” option in Preferences did the trick!!  Thanks so much for pointing me to that!  I’ll email you backchannel about integration with LaTeX/BibTeX.