Using two synced systems: "The output style specified is not available..." - but it is!

Dear community,

I’m using Endnote X7.7 in order to keep my references maintained during my master’s thesis.
In order to do so, I am writing on 2 different systems, my notebook aswell as my desktop PC.
Both run Win7, both have Endnote X7.7 Build 9832 installed an running. I sync my library using
Endnote Web which works like a charm, thank you! But, when it comes to working with Endnote
within Word 2016, I get into trouble.

I use MS OneDrive to work on my thesis - so when I’m finished working on my desktop,
I’ll upload the doc to the OneDrive and will lateron work with my notebook using the doc.
Adding or editing Citations using my desktop is fine. This actually works pretty good.

But whenever I try to add or edit a citation using my notebook, a small window pops up,

Getting list of available styles…
Getting list of available styles…

Ending in an error which says “The output style specified in this document, (stylename), is not available in your Styles folder. Please select another style or Cancel and make sure that the style is in the proper folder” - which I found to be very common while browsing through the community. But in my case - none of the solutions have worked.
I should add, that the style is an external style that I have gotten from my university (.ens). It is mandatory to use it.

What I have tried so far is:

  • make sure the style is imported properly

  • make sure the style is within the set style folders (C:/Users/MyUser/Documents/Endnote/Styles) on both systems

  • make sure the same style is chosen within the document (in the MS-Word Endnote toolbar) aswell as the endnote-application on both of my systems

  • reinstall Endnote (several times)

  • completely renamed the style, reimported it at both systems and made sure the files are within the set style folders

So right now, I don’t have any clue why it still won’t find the style on my notebook.
Fun-fact: Whenever I open Word on my notebook and open the Endnote-tab,
Getting list of available styles…
Getting list of available styles…
appears and closes without any(!) error. The error just appears whenever I try to add or edit a citation.

So, is there anybody who can relate to my problem? Is there an easy solution I just couldn’t find?

Kind regards and thanks in advance,