very slow when inserting citations


I have been using X4 for quite awhile but only about 2 weeks ago, I noticed that inserting in-text citations has become very slow. 

When I first noticed this slowness, I was editing a few documents that I hadn’t touched in a year and thought somehow the slowness was related to that. But then, I was having the same problem with my more recently created documents and also on different computers. So I am not sure what triggered it.

I tried removing the hyperlinking and it didn’t seem to make it any faster.  Each document is not large, about 1MB. I will be needing to combine several of these documents soon to form my thesis so I am quite worried the problem will get even worse once I merge all documents and the file size gets significantly larger. 

I am reluctant to turn off instant formatting because I am making sure all the citations and bibliography are consistent and correct as I go along to avoid spending a large amount of time fixing up those at the end.

Any suggestions and advice will be greatly appreciated.

Thank you.

The usual recommendation is to turn-off CWYW.  But if that’s not an option for you, have you tried testing (on a backup copy of your original document) unformatting then reformatting the citations/bibliography.

Also, there’s a patch to upgrade X4 to X4.0.2 - are you experiencing the slowdown with the installed patch? Also what’s the computer’s OS and MS Word version?  If you upgraded to X4 from an earlier version of the program did you uninstall that version first before installing X4?

To download the X4 patch and read the instructions go to:


Thanks for your help. What I have is X4.02 and I have the patch for a few months now. I am using Word 2003 and experiencing the same problem with both Windows XP and Windows 7.  There are no older versions of Endnote on the computers.

I tried unformatting and reformatting on a backup copy as suggested but it wasn’t any faster straight away.

P.S. After closing all the documents and reopening them and trying it again, it seems to be much faster now. I can still see a bit of “formatting bibliography” etc window but it is a lot faster than before. Thank you.

This can often be an effect from Track Changes. If you are using Track Changes, first try setting the view to Final instead of Final Showing Markup. If you are using Track Changes and that doesn’t help, you may have minor field code corruption. You should contact Tech Support to have them help you clean that out.

You should also consider turning off the hyperlinking (see this thread for procedure and also addresses the “tracked changes” settings.)

I have the very same problem, running MS Word 2010 and X 5.

My document is a couple of hnudred pages and a huge buibliography, but I too have an awesome (and failry new) 64 bit windows machine.

No other endnote installed…next idea, anyone?