Numbered references in alphabetical order

I’ve written a paper for my bachelor assignment, and am currently finishing up. I noticed just now that the template I have to follow has numbered references in alphabetical order. I however have used Endnote X3 (in word 2007, if that matters) using the style “Numbered”, but this numbers in order of occurence and not in alphabetical order. My question is, therefor, if the style I want (so numbered references but in alphabetical order) is possible within Endnote X3, and if I can just switch to it such that Endnote will do all that converting work for me!

I found the following topic using the search button (, but it doesn’t say exactly what style etc, just some in Medicine. Also it’s quite old, from end of 2008 and not sure what version of Endnote he was using either.

I hope you have some good advice!

Thanks in advance.

1 Like

Absolutely.  that is what Endnote does.  If the rest of the references looks eactly as you want, then you can edit it, and change the bibliography (and citation, if you want) sort order to alphabetical. There are several choices there depending on whether you want the secondary sort to be Title or maybe year.   

 What’s to be done if my choice is:  the secondary sort is year?

Thanks in advance for your help

You edit the output style.   See the attached GIF.  You first Edit>output style> edit “selected base style”.  then edit the bilbiography Sort Order (note there is also a place you could independently sort the citation groups, but that wouldn’t make much sense in a numbered bibliography)  and then choose your poison.  Either by author + Year+title or first Author+Year+other authors. 

Save As the style to a new name and then be sure you change the word document to utilize that new style.  Changing to it in the endnote program does not change the style already in use in a word document. 


Dear Leanne

I use your advise and find it very useful. Thank you very much.

best wishes

Azam Mahmoudi Aznaveh

Great thread! It solved exactly the problem I was struggling with. However, I have a question concerning how to format the in-text citations using the Numbered style. I need to distinguish between the following two types of in-text citations:

[1]               (no page number)

([2], 23)      (page number → need to add a parenthesis)

Currently the citation template is ([Bibliography Number], Cited Pages)

The problem, however, is how to let EndNote know that I only want to add the parenthesis when there is something in the Cited pages field?

Thanks in advance,


Is this in author instructions somewhere?  – I would see this as confusing, and would probably prefer to indicate this as [2, p. 23]  Which would be represented by [Bibliography Number|,*p^pp*Cited Pages|]  I think. The  * represents the “link adjacent” which appears in the citation template as a centered tiny diamond shape and has to be inserted manually from the insert field drop down.  The | is the “separation” pipe character and can be typed from the keyboard or inserted from the insert field drop down.  

Thanks for your quick reply, Leanne!

I also find it confusing (and a bit strange), but that’s the style of the journal I’m preparing a manuscript for…

([2], 23)      (page number → need to add a parenthesis)

then I would just manually insert the first parenthesis and have the field look like this?  

[Bibliography Number]|,*Cited Pages)|

but let me try a couple a things… 

I have a solution, if you never use this as a “grouped” citation.  See the attached image of the citation template options.  

You would edit your citation to include the pages field and after that, convert the citation to the Author (Year) option, and it now gives you want you want.  

How does that work for you?  If it does, I attach the modified style and you can copy the text from the appropriate field. in this one to your modified style?

Numbered -cited pages.ens (16 KB)

That’s a great solution!

However, then I would have to type the author name manually when using active references (“Williams [50] argues that…”) instead of letting EndNote generate the author name using the Author (Year) option.

Hmm, seems like either way I will have to insert something manually!

In a way, inserting the first parenthesis manually seems to be less extra work than inserting the author names manually (and less chance of making typos). However, when I try to format the Citation field in the way you suggested, that is:

[Bibliography Number]|,*Cited Pages)|

something strange happens. I press Save, but it seems like EndNote doesn’t save the last Separation marker |

When I close the edit output style window and reopen it again, the last Separation marker is simply gone! And without it, in-text citation looks like a mess…

Sigh.  Yes – I have that same bug too, now that I am testing it.  So  this is what worked. 

[Bibliography Number],*Cited Pages  in the template and inserting the close ) in the suffix, the page number in cited pages and adding the first ( manually to the text (as if you try to put it in prefix, it comes after the square bracket – )

PS, sent in a bug report. 

Great, thanks! (I also removed the comma from the Citations field and inserted it manually in the cited pages field, if not it will appear in all references)

I am encountering another problem, though. I’m not sure if it’s a bug or if I’ve managed to unknowingly change some settings while trying out different solutions.

The problem is that in those cases where I have multiple references, the result looks like this:

… [36,48],51]

The multiple references didn’t always look that way, at one point they looked quite normal (i.e. [36, 48, 51]), but somehow they seem to have changed as I made some other changes…

attach your output style and I will have a look at the bracket problem.  Also you probably need a “link adjacent” space between the comma and Cited Pages field to avoid having that comma show up I think.  That might be the problem with both.  

but I am seeing it too.  

Here’s the output style I’m using, it’s a modified version of the Numbered style

Journal of Chinese Political Science.ens (17.4 KB)

struggling.  Everything I try just makes things worse.  

me too… hahaha

I think the bracket problem is related to the Cited Pages field. If I remove the Cited Pages from the Citation field, the bracket problem disappears.

I’ve kind of found a way to get the references in the correct style, but it’s far from elegant and requires quite a lot of manual input.  Here’s what I did:

Citation field: Bibliography Number

Prefix field: [

Suffix field: ]

If page numbers: add the following to the suffix field: , pp. 1-2)